سی پنل یار، آموزش کار با سی پنل

پلاگین و قالب وردپرس به همراه آموزش و دانلود

رفع خطای utf8_general_ci: Fail در نصب بسته نصبی وردپرس

603بازدید
()

اگر هنگام نصب بسته نصبی وردپرس با خطای زیر مواجه شدید:

utf8_general_ci: Fail

علت آن قدیمی بودن قالب و بسته نصبی است. و در نسخه های جدید MYSQL و mariadb که روی سرور ها نصب می شود این خطا مشاهده شده است.

راه حل رفع خطای utf8_general_ci: Fail :

 

1- از طریق Options و legacy collation fallback support for unknown collations types

برای حل مشکل مطابق تصویر زیر باید تیک گزینه

یا

را فعال کنید که ممکن هست در بعضی قالب ها

 

بعد از فعال کردن این تیک روی Test Database بزنید اگر مشکل رفع شد که میتوانید قالب را در ادامه نصب کنید.

اما اگر مجدد خطا رفع نشد از روش دوم استفاده نمایید.

 

 

روش دوم از طریق فایل dup-archiv

اگر با روش اول مشکل رفع نشد وارد پوشه dup-installer شده و یک فایلی به نام dup-archiv را پیدا کنید.

توجه کنید عنوان این فایل ادامه دار هست و مثلا ممکن هست به شکل dup-archive__5c1a8c.txt باشد

بعد از باز کردن این فایل utf8 را سرچ کنید و utf8_general_ci را پیدا کنید. مطابق تصویر زیر:

حالا دو راه حل دارید هر کدوم را انجام دهید مشکل رفع میشود.

یا کلا سطر utf8_general_ci را حذف کنید با ” “  و , که مثل تصویر زیر شود:

یا اینکه utf8_general_ci را به utf8mb3_general_ci یا utf8mb4_general_ci  تغییر دهید.

 

با انجام یکی از این دو روش بالا مشکل شما حل خواهد شد.

 

این پست چقدر مفید بود؟

لطفا به مطلب امتیاز دهید

امتیاز / 5. تعداد رای:

تاکنون کسی امتیاز نداده است! اولین نفری باشید که به این پست امتیاز می دهد.

پاسخ دهید